Panopto Permissions

Issue 

Access to a Panopto video is denied, prompting a request for permission.

Environment

This can impact both web browsers and mobile devices.

Resolution

If an individual enrolled in a course with content access rights encounters a "Request Access" message to view a session, simply log into Panopto to obtain viewing permissions for that course. Clicking on the "Panopto Content" link in Canvas will transfer the individual's credentials to the Panopto system, which will include the individual in the Viewer Membership of that course. This should need to be done only once for the duration of the course.

Cause

Panopto verifies the enrolled student registry whenever someone clicks a content link. Once confirmed, Panopto will add the student to the VIewer membership.

*Caution, Instructors may try to use Panopto content from a previous semester instead of copying or moving the content to the current semester's Panopto Content folder. Doing so will cause the automatic enrollment described above to fail because the LMS enrollment list is from the current semester. Panopto will add students to the current semester's Panopto Content folder which is empty. The Panopto content the instructor wants to use is from the previous semester, not the current one and that folder has granted permission to last semester's students (not the current semester). There are ways to "make that work", but important features like grade book connection for Panopto Quiz results and Analytic data on students will not work correctly.

Details

Article ID: 16
Created
Mon 12/14/20 11:46 AM
Modified
Tue 4/2/24 4:05 PM